Quantcast

140cc lifan clutch not engaging (its not the cable either)

Mini Dirt Bikes & Pit Bikes Forum

Help Support Mini Dirt Bikes & Pit Bikes Forum:

TNGclips1

Member
Joined
Sep 22, 2016
Messages
9
Reaction score
0
I bought a 140 lifan motor to swap into a 100cc frame. Its all ready to go and in the frame but when i pull the clutch lever it doesn't do anything. (BTW it is actually pulling the lever on the motor so its not a cable issue. Please help don't want to spend much on someone to fix it rather try to do it myself. Any ideas?
 

TNGclips1

Member
Joined
Sep 22, 2016
Messages
9
Reaction score
0
If anyone actually reads this i fixed it by loosening the 4 clutch bolts enough not to hit the casing or fall out but almost on the last few threads.

Sent from my SM-G925I using Tapatalk
 

AntNZ

Well-Known Member
Joined
Dec 29, 2014
Messages
403
Reaction score
15
Location
west coast NZ
If anyone actually reads this i fixed it by loosening the 4 clutch bolts enough not to hit the casing or fall out but almost on the last few threads.

Sent from my SM-G925I using Tapatalk
Im pretty sure those bolts are supposed to be done up tight! new engine??? If not clutch plates could be fried.
 

TNGclips1

Member
Joined
Sep 22, 2016
Messages
9
Reaction score
0
I checked it after a few rides and its tight now bolts wont go kn anymore. Havnt had any trouble with clutch again.

Sent from my SM-G925I using Tapatalk
 
D

Daniel Hart

Guest
Yeah I had about the same issue ! My clutch lever was supper hard to pull In, I bought 2018 Apollo RFZ DBx18 for my kids I put a brand new Lifan 140cc engine in it and the clutch psi stiff! It was smelling burnt the first day riding. Guess I’ll try the same thing. I’ll lock tight with blue loctite.
 

Latest posts

Top