Coleman Bt200x mechanical governor settings

Mini Dirt Bikes & Pit Bikes Forum

Help Support Mini Dirt Bikes & Pit Bikes Forum:

Newbluke

New Member
Joined
Sep 3, 2020
Messages
3
Reaction score
0
Hello. I recently purchased a bt200x with no mods at this point. Rode it for about 10 minutes, but went through some tall weeds and the bike hasn’t idled in place since. When you start it, it wants to move unless you hold the clutch/brakes tight. I’ve seen several discussions with similar issues, but never found a definitive answer to what could be happening. Based on my best guess, I think I’ve narrowed it down to the mechanical governor. Does anyone have any experience with this? I tried resetting according to some instructions I found for similar motor, but that produced the same result(remove clutch, start bike and open butterfly to stop, rotate shaft to full clockwise position and tighten arm). Unfortunately, this proved ineffective.
I really don’t want to remove the the governor, add torque converter, remove idle screw, etc. I get the appeal of this, but I have some younger kids that will be riding this from time to time, and it has plenty of juice at this point. Ultimately, I’m just trying to get it back to running as it should out of the box.
Note- I ordered and replaced all springs in the idle mechanism. Also checked the throttle and throttle plate nut- no hang ups. Seriously frustrated at this point and hoping someone can provide some direction at this point. Any help would be GREATLY appreciated!
 

Cail.bt200x

Member
Joined
Jul 14, 2021
Messages
16
Reaction score
1
where the throttle plate is and gov screw is the spring there might be messed it and might be binding out and getting stuck
 

Cail.bt200x

Member
Joined
Jul 14, 2021
Messages
16
Reaction score
1
check out the throttle handle on bars and see if it is closing all the ways like when you take throttle off. another idea
 

Jagman45

New Member
Joined
Jun 15, 2021
Messages
3
Reaction score
0
Sounds to me after going through the high weeds one of your springs got messed with on the carburetor. I would double check those.
 

Latest posts

Top