Kx85 wouldnt run properly now won't even start need help

Mini Dirt Bikes & Pit Bikes Forum

Help Support Mini Dirt Bikes & Pit Bikes Forum:

Rizzo97

Well-Known Member
Joined
Jul 14, 2014
Messages
324
Reaction score
0
Location
Maryfarms QLD
Hey everyone. I got a old 2001 kx85 yesterday and me and my brother have been workin on it ever since trying to get it back in running order seeing As its been very neglected. The bloke I baught it off said it had just had a rebuild and taken for a few rides then left in the shed. Won't go into detail but it was in really bad shape! All fixed up now beside the fact it seems to leak gearbox/clutch oil into the bore and out the exhaust? Put enough in so it was about half full lookin through they eyeglass but now it's empty and was pissin oil out .. Needs a new o ring for the exhaust so it was just dripping from the bottom of the expansion chamber then running out when it ran, was running really weird so took carbie off again because I thought mabey I didn't get the float levle right and then it ran a lot better but I went to take off and it stalled nowI can't even get it to start? not really a 2 stroke wiz alli know is it's just had a top end rebuild and new reeds, plus I cleaned the carb and airbox before even attempting to start it and cleaned fule tank out and put fresh fule in, has spark -fule and did the old school thumb over sp hole comp test and seems to have good compression s no don't see why it won't run.. Thanks in advance for any help
 

Rizzo97

Well-Known Member
Joined
Jul 14, 2014
Messages
324
Reaction score
0
Location
Maryfarms QLD
Would I need to split the case to change the crank seals? If so how do I go about that.. been doing research and I'm pretty sure that's why it's leaking the oil, still no clue on why it won't start
 

my67xr

Miniriders Legend and Master Spanner Spinning Mode
Joined
Jul 29, 2010
Messages
11,982
Reaction score
79
Location
South Australia
Is it real thin black stuff dripping from the exhaust ? sounds like spooge to me ?
What ratio are you mixing the fuel oil to ?

i dont know why a rebuilt engine would need new seals either ?
 

Rizzo97

Well-Known Member
Joined
Jul 14, 2014
Messages
324
Reaction score
0
Location
Maryfarms QLD
Yea it is thin and black, 32:1, would have to be a lot of spooge to be pissin out ? Top end rebuild dosnt include crank seals as far as I know ..
 

Rizzo97

Well-Known Member
Joined
Jul 14, 2014
Messages
324
Reaction score
0
Location
Maryfarms QLD
I thought it was spooge untill it started pissin when i gave it a bit of throttle..
 

my67xr

Miniriders Legend and Master Spanner Spinning Mode
Joined
Jul 29, 2010
Messages
11,982
Reaction score
79
Location
South Australia
it can still run with bad crank seals, but it'll blow a heap of white smoke out the muffler, you would have noticed it when you started it up
 

Rizzo97

Well-Known Member
Joined
Jul 14, 2014
Messages
324
Reaction score
0
Location
Maryfarms QLD
Yeah it blew like a constant stream of white smoke, think its got somthing to do with the float valve after reading another thread about a kx85 with fule spark and comp, the tip looked in good nick but there could be some gunk in where it resides gona have a look in the morning. Seems like its getting flooded
 

my67xr

Miniriders Legend and Master Spanner Spinning Mode
Joined
Jul 29, 2010
Messages
11,982
Reaction score
79
Location
South Australia
ok,
if it needs the cranks seals done, then i'm guessing no the cases wont need splitting.
if it's anything like a Yamaha or Suzuki then it's just a matter of removing the flywheel and stator from one side,
and the clutch cover and possibly the clutch or drive gears etc off the crank on the other.
then you can get to the seals to replace them
 

Rizzo97

Well-Known Member
Joined
Jul 14, 2014
Messages
324
Reaction score
0
Location
Maryfarms QLD
Sweet dosnt sound to hard, found the culprit it was the float valve the little bit that springs up and down that shouldn't be depressed when cheacking float level not sure what it's actually called but it kept sticking .. Any way to fix that or just get a new one ?
 

Rizzo97

Well-Known Member
Joined
Jul 14, 2014
Messages
324
Reaction score
0
Location
Maryfarms QLD
Got it to spring back up properly and not stick I left the bottom in a lid of petrol and little black bits of grit were in there, it runs good now but every time I go To take off on it it dies and then won't start properly for ages then gose good again then same thing.. Any ideas?
 
Joined
Jun 13, 2013
Messages
3,138
Reaction score
16
Location
stowport tas
Id imagine same problem, might pay toflush the tank if you havnt all ready, soundd like its full of crap and its blocking the needle and seat, not letting the bowl fill up quick enough. Just a thought..
 

Rizzo97

Well-Known Member
Joined
Jul 14, 2014
Messages
324
Reaction score
0
Location
Maryfarms QLD
Took the clutch cover and the case behind that off and Iv found a rubber ring snapped and some metal bits with tini springs in a little pool of trans oil and can hear what sounds like the crank bearings or at least the balls from them getting moved around wheni spin the clutch am just going to rebuild the bottom end and see how it all gose, anyone got any ideas on where the Mini springs came from so I can buy whatever They are or what's need to fix em
 

Rizzo97

Well-Known Member
Joined
Jul 14, 2014
Messages
324
Reaction score
0
Location
Maryfarms QLD
Took the bore off and there is a pool of what looks like trans oil at the bottom of the crank and more mini springs with metal bits? Don't have a clue where theyv come from, need a socket I don't have to get clutch off and a flywheel puller to split the cases think its the clutch crank seal that's f'd is this why it won't run properly? Everything else looks fine
 

zwebx

Well-Known Member
Joined
Sep 3, 2012
Messages
3,296
Reaction score
16
Location
Melbourne
Took the bore off and there is a pool of what looks like trans oil at the bottom of the crank and more mini springs with metal bits? Don't have a clue where theyv come from, need a socket I don't have to get clutch off and a flywheel puller to split the cases think its the clutch crank seal that's f'd is this why it won't run properly? Everything else looks fine
Most certainly why.
I would go through every bearing and get a new rod installed while you are at it
 

jev

Well-Known Member
Joined
Oct 28, 2014
Messages
52
Reaction score
0
Pictures will show what you are talking about
 

Rizzo97

Well-Known Member
Joined
Jul 14, 2014
Messages
324
Reaction score
0
Location
Maryfarms QLD
Looks like the Rubber ring has come from the inside of the main crank seal I can see a big gap through to the bearing.. Are the little springs from the seal mabey?
 

my67xr

Miniriders Legend and Master Spanner Spinning Mode
Joined
Jul 29, 2010
Messages
11,982
Reaction score
79
Location
South Australia
Can you see how hard it is for us to help you out with out pics ?
I thought you were using an IPad , they have cameras don't they ?



this is a crank seal





do the metal spring parts look a bit like that ^^ ?
they would be wound pretty tight, and each coil would be touching the next

here's a simplified cutaway view too





Can you sort of hear each bearing clicking against the next as you turn the engine over ?,
If so then the bearing has gone, the cage that seperates each bearing has failed and ripped the rubber out the seal.
 
Last edited:

Latest posts

Top