loncin engine problem

Mini Dirt Bikes & Pit Bikes Forum

Help Support Mini Dirt Bikes & Pit Bikes Forum:

LOWLYF

Member
Joined
May 25, 2009
Messages
7
Reaction score
0
hey guys

my bike is missing real bad, kinda stalling at about 1/2 to 3/4 rpm. if i stay into it it picks back up after 1 or 2 seconds and the nevs out ok. its making ok power still just doing the stalling thing.
its a loncin 125 air cooled
i have replaced the spark plug, filter,carby adapter and gasket and have cleaned carby out twice and blew out jets with a compressor, new fuel and fuel filter which seemed to work but i went on a long ride the other day and it started again.
im thinking carby prob still but its got me stumped.
iv worked on heaps of 2stroke motors but not really 4 stroke motorbike motors, am i missing something that you could suggest?
 

pooley770

Member
Joined
Jul 20, 2009
Messages
10
Reaction score
0
Location
Morwell VIC AUS
Idea

my bike was doin similar thing and found out it was skipping spark somewhere so i made up a new wiring lume and it was all good again let me know how you go if you try this
 

LOWLYF

Member
Joined
May 25, 2009
Messages
7
Reaction score
0
hey guys

sorry i no this might sound stupid but what is your sig?

do i need to change the cdi unit when i re wire the bike or just use the old stuff?

I just put a new carby on it and it seemed to run a bit smoother but it didnt fix the problem. thanks guys
 

sarahjane

New Member
Joined
May 30, 2013
Messages
1
Reaction score
0
hey guys

my bike is missing real bad, kinda stalling at about 1/2 to 3/4 rpm. if i stay into it it picks back up after 1 or 2 seconds and the nevs out ok. its making ok power still just doing the stalling thing.
its a loncin 125 air cooled
i have replaced the spark plug, filter,carby adapter and gasket and have cleaned carby out twice and blew out jets with a compressor, new fuel and fuel filter which seemed to work but i went on a long ride the other day and it started again.
im thinking carby prob still but its got me stumped.
iv worked on heaps of 2stroke motors but not really 4 stroke motorbike motors, am i missing something that you could suggest?
could possibly be your coil pack, mine did the same thing.
 
N

Nicholas Huntley

Guest
hey guys

sorry i no this might sound stupid but what is your sig?

do i need to change the cdi unit when i re wire the bike or just use the old stuff?

I just put a new carby on it and it seemed to run a bit smoother but it didnt fix the problem. thanks guys
Any idea where I can get a new rotor / flywheel for a Loncin ATV no. LC 152 FMH engine please? I’ve tried the internet but it’s it doesn’t seem to be listed anywhere. The spark energiser magnet on the outer rim seems to have lost it’s magnetic power (Zero magnetism).
Thanks,
Nick.
 

Latest posts

Top