Mini bike shakes violently.

Discussion in 'Mini Chat' started by Streetride14, Feb 16, 2016.

Mini Dirt Bikes

Help Support Mini Dirt Bikes:

  1. Feb 16, 2016 #1

    Streetride14

    Streetride14

    Streetride14

    Member

    Joined:
    Feb 16, 2016
    Messages:
    5
    Likes Received:
    0
    i have a doodlebug frame with a 6.5 hp engine. when ever i go 0 to 1/4 throttle the bike rides fine but when i go 1/4 to 3/4 throttle the bike shakes violently. after 3/4 throttle it rides fine again and docent shake.

    does anyone know how to fix this.
     
  2. Feb 16, 2016 #2

    motorman

    motorman

    motorman

    Admin "The Cougar"

    Joined:
    Nov 14, 2008
    Messages:
    6,213
    Likes Received:
    49
    Location:
    Victoria
    Are all your engine brackets holding motor to frame bolted in firmly?
     
  3. Feb 16, 2016 #3

    my67xr

    my67xr

    my67xr

    Miniriders Legend and Master Spanner Spinning Mode

    Joined:
    Jul 29, 2010
    Messages:
    11,982
    Likes Received:
    77
    Location:
    South Australia
    Welcome to Minirider's

    Check that the engine mounting bolt's are all tight.
    It may need to have the frame braced with some thicker steel to hold the engine in better
    I have heard of people welding 6mm plate's to the underside of the frame/engine mounting plate and redrilling it for the mounting bolt's
    Use some better quality high tensile bolt's and nut's too while you are at it, may need to be 6mm+ longer ?
     
  4. Feb 16, 2016 #4

    Streetride14

    Streetride14

    Streetride14

    Member

    Joined:
    Feb 16, 2016
    Messages:
    5
    Likes Received:
    0
    yes all bolts and the motor mount are securely holding engine
     
  5. Feb 16, 2016 #5

    Streetride14

    Streetride14

    Streetride14

    Member

    Joined:
    Feb 16, 2016
    Messages:
    5
    Likes Received:
    0
    all bolts are tight
     
  6. Feb 16, 2016 #6

    motodevo

    motodevo

    motodevo

    Miniriders OG Master Spanner Spinner

    Joined:
    Sep 19, 2007
    Messages:
    663
    Likes Received:
    24
    Location:
    in the shed
    Maybe chock it up so the rear wheels off the ground and rev it up, might give you a clue to the issue. I'd be looking at the clutch especially
     
  7. Feb 16, 2016 #7

    my67xr

    my67xr

    my67xr

    Miniriders Legend and Master Spanner Spinning Mode

    Joined:
    Jul 29, 2010
    Messages:
    11,982
    Likes Received:
    77
    Location:
    South Australia
    Did you do the 6.5hp conversion to it ?
    Is it the Predator 212 engine ?

    [​IMG]

    There's a few people on the net that mention the engine need's to be lifted 1/2" and the chain tensioner relocated

    [​IMG]



    [​IMG]

    [​IMG]


    Some have fitted a torque convertor too

    [​IMG]

    [​IMG]
     
    Last edited: Feb 16, 2016
  8. Feb 16, 2016 #8

    Streetride14

    Streetride14

    Streetride14

    Member

    Joined:
    Feb 16, 2016
    Messages:
    5
    Likes Received:
    0
    Yes I'll try that
     
  9. Feb 16, 2016 #9

    Streetride14

    Streetride14

    Streetride14

    Member

    Joined:
    Feb 16, 2016
    Messages:
    5
    Likes Received:
    0
    Yes it the predator. I'll try the 1/2" lift and chain tension.
     
  10. Feb 17, 2016 #10

    Dirt Burd

    Dirt Burd

    Dirt Burd

    Well-Known Member

    Joined:
    Feb 4, 2016
    Messages:
    151
    Likes Received:
    0
    I bought a brand new one, it had the 3 hp engine, the wheels and tires are junk. Nothing was balanced. I dumped it. Full throttle is jumped and shook. I got $250 out. And ran.
     
  11. Oct 27, 2019 #11

    Tac1230

    Tac1230

    Tac1230

    New Member

    Joined:
    Oct 27, 2019
    Messages:
    1
    Likes Received:
    0
    Did you ever figure it out?

    I just bought a used db30 with the same issue.
     

Share This Page

arrow_white