Quantcast

yx160 clutch problem

Mini Dirt Bikes & Pit Bikes Forum

Help Support Mini Dirt Bikes & Pit Bikes Forum:

spoonta68

Well-Known Member
Joined
Dec 7, 2007
Messages
598
Reaction score
6
hey all recently just installed a doner yx160 into my tard just to get it moving and im having the follouing problems

once i install the cable and screw adjuster on engine to the min it seem to pull and engage clutch as if i were pulling it

ive just bought a longer 110cm cable with 14cm pull and on the min settings its pulling the arm forard enough to engage clutch


i disconected the cable and put it in gear and it wont roll in gear but with the cable attached its causing it to roll

sorry about the discription just can word it as im seeing it lol


please help as i wanna get this snot rocket going


regards
 

Blender

Well-Known Member
Joined
Apr 16, 2013
Messages
2,845
Reaction score
22
Location
Goolmangar, Nsw
it sounds like the cable u got didnt have enough travel , because the sheathe is too long. the same thing happened to me with my new bike, i was able to modify it to fit though.
Did you compare the cable u have to the one the engine originally used ?

but, it may be not enough oil circulating the clutch, therefore not allowing it to engage. try pulling the clutch in and moving the bike back and forth, while revving it to help circulate the oil.
 

spoonta68

Well-Known Member
Joined
Dec 7, 2007
Messages
598
Reaction score
6
i got the longest travel cable possibe as ive tried 3 in the last week and the other 2 were to short
im gonna trim down the cable bracket and this will give me the extra i need
without the cable connected and it in gear the clutch defintly isnt engaged and it refuses to roll

sorry i got confued with the htrottle cable is bought also
this is what i bought
Thumpstar Pitbike PIT Bike Trail Clutch Cable 105cm Long | eBay
 

lewisbroon2018

New Member
Joined
May 27, 2020
Messages
1
Reaction score
0
I Have a YX160 clutch problem wont engage atall exausted all options by buyin 3 different clutches numerous ways ect, any ideas ? All built correctly.
 
O

Ozzy

Guest
I Have a YX160 clutch problem wont engage atall exausted all options by buyin 3 different clutches numerous ways ect, any ideas ? All built correctly.
I am facing the same propblem i bought a brand new yx 160 but the clutch doesn't seem to do anything.
 

Mininube

New Member
Joined
Aug 13, 2020
Messages
2
Reaction score
0
Hi, I'm new to the forum but might have some insight about this. I have a Daytona 190 that was experiencing the same issue. The clutch compresses with a a small plunger that moves in and out with the rotation of the arm that the clutch cable attaches to. Make sure whatever ramp device is on the clutch is set to the correct orientation to compress the springs when the cable is pulled in and releases them when let out. I also have a YX150 motor that I could compare it to to see how the ramp works on the YX motors. I hope this helps. :)
 

Latest posts

Top