Quantcast

107cc Chinese quad starts but will not rev

Mini Dirt Bikes & Pit Bikes Forum

Help Support Mini Dirt Bikes & Pit Bikes Forum:

davidwf

New Member
Joined
Aug 15, 2020
Messages
3
Reaction score
1
One of those Chinese YB110 mini quads came to me as the local engine guru :rolleyes: to "have a look can you as it wont rev....was OK last time it was used".....which turned out to be some 6 years ago!!!
the plug was thick black and sooty and sure enough it wouldnt rev past a very lumpy and un-happy idle
first thoughts were carb so after cleaning it I ended up replacing it and the spark plug...well, they are cheap enough....but it was no better
I had just changed the oil (of which there was hardly any in it) and checking again after maybe 30 seconds of idling it was very black, stank of combustion fumes and there was a lot of air coming out of the filler plug hole and oil breather pipe
I then looked a bit deeper and found this horror story....oh dear
new block & piston set duly ordered

what might have caused this....it did used to run OK as I had it in for an oil change when it was last used
 

Attachments

Last edited:

Goz007

New Member
Joined
Jul 14, 2018
Messages
1
Reaction score
0
Location
Sydney
Have u ever used areo start or start u bastard or some sort of starting spray? Its known to brake ring lands & wreck engines....
 

davidwf

New Member
Joined
Aug 15, 2020
Messages
3
Reaction score
1
no, nothing like that ever
I have since found that the CDI unit was faulty....having replaced that and re-built the engine it is now running well
 

Latest posts

Top