MIKUNI 25mm CARBIE MANUAL.

Mini Dirt Bikes & Pit Bikes Forum

Help Support Mini Dirt Bikes & Pit Bikes Forum:

foolsp33d

Well-Known Member
Joined
Feb 5, 2007
Messages
2,700
Reaction score
14
Anyone looking for information or considering a carbie swap is urged to click the following link and READ CAREFULLY. If you still do not understand what is wrong, THEN post up a question in relation to the problem.
Hope this can save on reposts and simple problems.

http://www.elstars.com.au/pdf/manual/mik-c25m.pdf
 

PICCOLO

Well-Known Member
Joined
Jan 16, 2007
Messages
110
Reaction score
0
Location
Mudgee NSW Austraila
Hmm thanks m8 i had it already but thanks for putting it up im sure if everyone reads this they will learn somthing
 

mangus!!

Well-Known Member
Joined
Mar 8, 2007
Messages
46
Reaction score
0
ask questions ay,
u basically called me a ****head b4 for doing that!
 
Last edited by a moderator:

foolsp33d

Well-Known Member
Joined
Feb 5, 2007
Messages
2,700
Reaction score
14
:rolleyes: come on now mate.. language.. and settle.. Did you do search BEFORE asking the question!? in all honesty, its a simple thing to come onto a site and post up and expect answers.. its another to actually do some research of your own before relying on others..

Its what the search button is for :D
 

Pittin

Well-Known Member
Joined
Mar 12, 2007
Messages
607
Reaction score
0
Location
Redcliffe Qld
Mikuni Problems!!!!!!!

Hey, I got a 25mm Mikunio carbie on aducar 125 and when ever i gun it at start it just floods. Ive tried Changing idle mixture but there isnt no air screw ?!?!?!?!?!?!? I dunno whether the jets need cleaning but and help would be useful

Cheers :)
 

kyunt

Well-Known Member
Joined
Mar 4, 2007
Messages
87
Reaction score
0
sounds silly but is your choke on?
 

kyunt

Well-Known Member
Joined
Mar 4, 2007
Messages
87
Reaction score
0
iv seen some post on this site were there was an answer like that and the person goes shit, thanks!!!

lol
 

Pittin

Well-Known Member
Joined
Mar 12, 2007
Messages
607
Reaction score
0
Location
Redcliffe Qld
ha ha ha ha haaaaaaaa

What a fool

I think i might run some fuel cleaning shit through and i might get a fuel filter.
 

geezus18

Well-Known Member
Joined
Apr 25, 2006
Messages
916
Reaction score
0
Location
Victa , SA
are you sure its flooding or could it possibly be getting starved of fuel? check the fuel hose and also make sure your air filter is clean..try running the bike without the air filter and see if it still does the same thing.
 

pegleg

Well-Known Member
Joined
Mar 7, 2007
Messages
658
Reaction score
0
Location
Newy
Hi,
My sons 29 also has a mikuni and Ducar 125, and has the same problems, once the revs are up it revs ok, but from and idle, he has to slowly apply the throttle or it just seems to choke. I have tried moving the needle up and down,with no results, as the spark plug is a nice brown colour, not choked up with deposits nor white, so I am not sure about dicking around with the mixture screw too much. coming out of a berm or just before he hits a jump is not the ideal time for it to have a huge flat spot.
So having said that I would also be interested in any suggestions from the highly knowledgeable ppl from this here forum....
 

pegleg

Well-Known Member
Joined
Mar 7, 2007
Messages
658
Reaction score
0
Location
Newy
Oh I forgot to add, he has a new Unifilter, but it happened before and also with no filter.
 

Pittin

Well-Known Member
Joined
Mar 12, 2007
Messages
607
Reaction score
0
Location
Redcliffe Qld
Thnaks guys, Ill give em all a go, Just a word of warning though....NEVER EVER BUY A FOXICO... My forks bottom out while stopping, Fork oil did nothing, chain snapped first ride and now carbie truobles, Oh well its all good fun
 

kyunt

Well-Known Member
Joined
Mar 4, 2007
Messages
87
Reaction score
0
yeah if you move the eclip, what out when unscrewing the lid. Cos i got a spring in the eye ;)

lol :D
 

Pittin

Well-Known Member
Joined
Mar 12, 2007
Messages
607
Reaction score
0
Location
Redcliffe Qld
But i have also added a 2stage UNI filter, works heaps better but still got carbie problems.
 

pitmaster

Well-Known Member
Joined
Mar 9, 2007
Messages
1,137
Reaction score
0
Location
SA
Eclip is in the top of the carby, where the cable screws into carby,

the tube looking thing with the screw cap on it and the throttle cable coming out the top of it,

you unscrew the lid, and pull the throttle slide out, and theres a pin going down the middle, with 2 springs, a big one, and once thats removed, a tiny spring holding the eclip down, WATCH OUT IT WILL POP OUT AND YOULL LOOSE IT REAL EASY!!!

once the springs are removed, the pin will slide out, and youll see a tiny clip on the pin, the pin will have about 5 grooves/slots on it, you carefully pull the clip off and move it up or down on the pin,

moving the CLIP UP will LEAN IT OUT
CLIP DOWN will RICHEN IT

only move it 1 slot at a time, than re test,

MAKE SURE YOU LOOK HOW IT ALL WORKS BEFORE PULLING SPRINGS OUT ETC,

and when you reinstalling the slide in the carby, it will only go back in ONE way,

I doubt very much this will fix your problem, sounds more like dirty carby, or you have fiddled with mixture screws too much!!!
 

Latest posts

Top