yamoto explorer...dont bother

Discussion in 'Minibike Reviews' started by headsmess, Mar 4, 2009.

Mini Dirt Bikes

Help Support Mini Dirt Bikes:

  1. Mar 4, 2009 #1

    headsmess

    headsmess

    headsmess

    Miniriders OG

    Joined:
    Feb 9, 2009
    Messages:
    1,520
    Likes Received:
    14
    Location:
    sydney... north of
    so i got one of these things over a month ago....
    prick up there in qld saying as soon as i get my compliance plate, i wizz down to the RTA with a ctp(green slip)and hey presto, rego is like sparking a smoke:)

    ahem...so why have i been to the rta three times in three days?
    and STILL no rego?

    at the RTA..."you need a blue slip, first registration, it needs a blue slip" i was told i didnt...this earnt raised eyebrows from ppl at RTA, the mechanic i went to, my mates, me, anyone thats registered anything without rego on it.... so i went and got my blue slip...

    next"you need a new ctp"...ok, the wank mechanic put my vin number in wrong...thats cool....fixed that.

    so now, i got it all sorted:)....or so i thought "your vin isnt on this import approval"... so i ring my good buddies at motovert,(trust me, ive had to ring them a LOT) yeah sure, well fax that page through... as they then do. this being the first thing, other than taking my money, that theyve done promptly....

    then the chick behind the counter at the RTA tells me i need a third tier inspection... a what?:eek:

    now the dumkopf at motorevo is trying to tell me hes sold heaps in NSW, and im the first person to have these troubles....so

    ANYONE ELSE IN NSW BOTHERED GETTING ONE, THEN REGISTERED IT?

    the saga continues in that...my speedo doesnt work cause they dont check the crap theyre selling.... ie, parts missing....not that big deal until i get this inspection next week...when it better be working...

    and seeing as it took 2 weeks for my compliance plate to arrive, from brisbane... a ten hour drive away....
    i dont expect my speedo to be working unless i make something....

    once again...ANYONE IN NSW REGISTERED AN EXPLORER? and what were youre experiences?
     
    Last edited: Mar 4, 2009
  2. Mar 4, 2009 #2

    Dabomb

    Dabomb

    Dabomb

    Well-Known Member

    Joined:
    Jul 10, 2005
    Messages:
    1,477
    Likes Received:
    9
    Location:
    Newcastle
    you have to buy a compliance plate seperate? did you have the option?
    is ur speedo sensor hooked up properly?

    lol should of bought a rx bru!
    mine was no hassle, blueslip->order plates->greenslip->present slips at rta and pickup plates->done!
    had all my engine work and some other mods done before the blueslip too!
     
  3. Mar 4, 2009 #3

    headsmess

    headsmess

    headsmess

    Miniriders OG

    Joined:
    Feb 9, 2009
    Messages:
    1,520
    Likes Received:
    14
    Location:
    sydney... north of
    no, they didnt include the lil rotor tht spins with the wheel..so i got a sensor that has nothing to sense...

    to get the compliance plate was free...except having to pay an "authorised workshop" to assemble it...at least delivery through works TNT account was free...

    and it was less than getting motorevo to assemble it, and deliver it with the compliane STICKER actually....


    yeah, shoulda saved my dosh and gotten something with a name behind it:(

    even my postie would have been easier and quicker
     
  4. Mar 4, 2009 #4

    Dabomb

    Dabomb

    Dabomb

    Well-Known Member

    Joined:
    Jul 10, 2005
    Messages:
    1,477
    Likes Received:
    9
    Location:
    Newcastle
    i see....i have the same speedo sensor problem....my new disks didnt come with a magnet embeded in the disk like the old disk....mite epoxy one in there or something.
     
  5. Mar 4, 2009 #5

    headsmess

    headsmess

    headsmess

    Miniriders OG

    Joined:
    Feb 9, 2009
    Messages:
    1,520
    Likes Received:
    14
    Location:
    sydney... north of
    so im of the idea its just one magnet? seeing as i dont have the thing in front of me to copy directly..., and im gunna get on my lathe tomorrow before work... bastard if it has three or something silly...
    i am not waiting two weeks for them to get their act together and send me a replacement...
    dumkopf even wanted me to send the unit back up first:eek:
    but yay!!!i pulled it apart and wizzzed a magnet around inside and hit 22kmh:) just gotta find that lump of alloy i got tucked away....
     
  6. Mar 5, 2009 #6

    headsmess

    headsmess

    headsmess

    Miniriders OG

    Joined:
    Feb 9, 2009
    Messages:
    1,520
    Likes Received:
    14
    Location:
    sydney... north of
    yay!!made my sensor!!!!
    note, BEFORE you glue that magnet in, work out which way up it has to go...north or south?

    i just had to drill the sucker out and glue it back the ther way:eek:

    now road test to see if the speeds right... it might use two magnets:(
     
  7. Mar 5, 2009 #7

    headsmess

    headsmess

    headsmess

    Miniriders OG

    Joined:
    Feb 9, 2009
    Messages:
    1,520
    Likes Received:
    14
    Location:
    sydney... north of
    one road test later...my suspicions proved right...two magnets:(

    wee! just overtook someone in a 60 zone and im reading 42.....
     
  8. Mar 5, 2009 #8

    SnItChY

    SnItChY

    SnItChY

    Banned

    Joined:
    Jun 23, 2007
    Messages:
    2,406
    Likes Received:
    31
    Location:
    gold coast
    hmmm i got an imported Honda 1974 z50j1 and it only got a ADR compliance ,3 weeks b4 i bought it ,went to RTA all sweet my son you got a plate ,you got import papers ,heres ya plates ,see ya


    was to easy ,BTW i may only top out at 60 km but man i sure do look good doing it ,oh and the coppers hate it
     
  9. Mar 5, 2009 #9

    headsmess

    headsmess

    headsmess

    Miniriders OG

    Joined:
    Feb 9, 2009
    Messages:
    1,520
    Likes Received:
    14
    Location:
    sydney... north of
    the cops is why i got this:p

    i had a 74 c90..that was easy. really easy. ah, the memories.... when i finally took it off the road it wasnt even the same bike:p engine, frame, forks...you name it...different bike...reason i didnt re register it...

    this thing? ha!
     
  10. Mar 16, 2009 #10

    headsmess

    headsmess

    headsmess

    Miniriders OG

    Joined:
    Feb 9, 2009
    Messages:
    1,520
    Likes Received:
    14
    Location:
    sydney... north of
    :rolleyes: finally registered... wow.

    what a giggle riding this thing through the traffic...

    topped out at 106km/h today:) actually feels stable too.

    now just the clutch is driving me mad. it is not good.

    6/10, mainly for novelty factor.

    and this part for my speedo still isnt here either.... despite being told it would get posted a fortnite ago....
    meh. it works.
     
    Last edited: Mar 16, 2009
  11. Mar 16, 2009 #11

    Dabomb

    Dabomb

    Dabomb

    Well-Known Member

    Joined:
    Jul 10, 2005
    Messages:
    1,477
    Likes Received:
    9
    Location:
    Newcastle
    sweet....its nice and legal without a working speedo!

    hey i got new disc's without the magnet to pickup my speed....i epoxied the magnet from the old disc into a hole in the new one...works great....it lines up and everything!
     
  12. Mar 16, 2009 #12

    motoluver

    motoluver

    motoluver

    Well-Known Member

    Joined:
    Mar 7, 2007
    Messages:
    1,223
    Likes Received:
    1
    Location:
    Newcastle
    How much is the motovert rx. Might get one instead of a postie.
     
  13. Mar 16, 2009 #13

    mini mad

    mini mad

    mini mad

    Well-Known Member

    Joined:
    Dec 16, 2008
    Messages:
    88
    Likes Received:
    0
    Location:
    Wagga Wagga N.S.W
    $1899 for the 50cc rx and $3000 for the 125cc. i just picked up a moto vert rx it was used for a demo bike only done 24km i got it for $1125
     
  14. Mar 17, 2009 #14

    motoluver

    motoluver

    motoluver

    Well-Known Member

    Joined:
    Mar 7, 2007
    Messages:
    1,223
    Likes Received:
    1
    Location:
    Newcastle
    Going to check the rx50 out tomorrow at east coast 50s cheers fellas.
     
    Last edited: Mar 17, 2009
  15. Mar 17, 2009 #15

    LTN16

    LTN16

    LTN16

    Well-Known Member

    Joined:
    Oct 19, 2008
    Messages:
    102
    Likes Received:
    0
    Location:
    Victoria, AUSTRALIA
    I seen that on eBay and thought it was a good buy for that price.

    I was very tempted to buy it so your lucky..
     
  16. Mar 17, 2009 #16

    Dabomb

    Dabomb

    Dabomb

    Well-Known Member

    Joined:
    Jul 10, 2005
    Messages:
    1,477
    Likes Received:
    9
    Location:
    Newcastle
    i picked my rx125 for 1600 with 400ks on it!
     
  17. Mar 17, 2009 #17

    mini mad

    mini mad

    mini mad

    Well-Known Member

    Joined:
    Dec 16, 2008
    Messages:
    88
    Likes Received:
    0
    Location:
    Wagga Wagga N.S.W
    Yep i think i got a good deal on me motovert but the rx 50 goes real slow so i just pulled the engine out i am fitting a 140cc today.
     
  18. Mar 18, 2009 #18

    LTN16

    LTN16

    LTN16

    Well-Known Member

    Joined:
    Oct 19, 2008
    Messages:
    102
    Likes Received:
    0
    Location:
    Victoria, AUSTRALIA
    The 140 should be heaps better. How do you go about fitting the lights and that up to it though ?
     
  19. Mar 18, 2009 #19

    mini mad

    mini mad

    mini mad

    Well-Known Member

    Joined:
    Dec 16, 2008
    Messages:
    88
    Likes Received:
    0
    Location:
    Wagga Wagga N.S.W
    easy on the lifen engine it has all 6 wires so i just cut the plug off the old 50cc engine and wire it into my 140cc engine and plug it up and away i go its all done now its in and running so i will take me new toy out for a run when it gets dark
     
  20. Mar 18, 2009 #20

    rosie

    rosie

    rosie

    Well-Known Member

    Joined:
    Dec 30, 2008
    Messages:
    131
    Likes Received:
    0
    Location:
    wollongong
    where do u get the compliance plates from we bought a xr250 the other day but the compliance plate had been taked of to paint it and then the guy who done it has lost it
    brendan
     

Share This Page

arrow_white